87 Grand Am Stalls When Put In Drive

Reply

  #1  
Old 01-29-06, 06:45 PM
rrw
rrw is offline
Member
Thread Starter
Join Date: Jan 2006
Posts: 3
87 Grand Am Stalls When Put In Drive

1987 GRAND AM STALLS WHEN PUT IN DRIVE. 3 OTHER MECHANICS SAID TO REPLACE TRANNY AS IT APPEARED TO BE LOCKED UP INSIDE. SO WE REPLACED TRANNY. CAR STARTED OK AND DIDN'T STALL WHEN PUT IN DRIVE. APPEARED TO DRIVE FINE ALSO. A FEW MILES DOWN THE ROAD AFTER A SHORT STOP AT STORE IT STALLED AGAIN WHEN PUT IN DRIVE AND ORIGINAL PROBLEM IS BACK EXACTLY AS BEFORE. ANY IDEAS VERY WELCOME
 
Sponsored Links
  #2  
Old 01-29-06, 07:31 PM
Member
Join Date: Dec 2001
Posts: 2,538
will it go into gear without dying after it has set for awhile?
what size engine?
 
  #3  
Old 01-29-06, 07:38 PM
rrw
rrw is offline
Member
Thread Starter
Join Date: Jan 2006
Posts: 3
Originally Posted by bejay
will it go into gear without dying after it has set for awhile?
what size engine?
It won't go into gear without dying now at all. Engine is 3.0 ltr .
 
  #4  
Old 01-29-06, 08:08 PM
Member
Join Date: Dec 2001
Posts: 2,538
suggest seeing a shop for a diagnossis I would suspect it would be an electrical problem either in the electronic engine controls or damaged wiring harness it could take a while to find.
was the torque convertor replaced with the transmission?
 
  #5  
Old 01-29-06, 11:54 PM
rrw
rrw is offline
Member
Thread Starter
Join Date: Jan 2006
Posts: 3
Originally Posted by bejay
suggest seeing a shop for a diagnossis I would suspect it would be an electrical problem either in the electronic engine controls or damaged wiring harness it could take a while to find.
was the torque convertor replaced with the transmission?
THANKS. WE'RE THINKING ELECTRICAL TOO AS IT HAS SOME LIGHTING PROBLEMS THAT SEEM TO BE CAUSED A SHORT SOMEWHERE TOO. TRIED TO FIND OUT WHY THE SHORT BUT IT'S BEING VERY HARD TO FIND TOO. TORQUE COVERTER WAS REPLACED WITH TRANNY THOUGH.
 
  #6  
Old 01-30-06, 04:25 PM
Member
Join Date: May 2005
Posts: 93
sounds like it may be that the torque converter isnt unlocking try unplugging the four pronged plug on the radiator side of the trans then try it. ive seen this alot on those cars
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'