Ford Taurus major electrical issue....

Reply

  #1  
Old 02-17-06, 05:45 AM
Member
Thread Starter
Join Date: Mar 2002
Location: illinois
Posts: 183
Ford Taurus major electrical issue....

A friend owns a 2001 Ford Taurus station wagon.... all of a sudden his power door locks, dash lights, radio, windshield wipers, rear window defroster etc. all quit working. He checked the fuses, all good. He swapped a couple relays with each other, problem still there. What do all these have in common?? Any ideas would be appreciated!
 
Sponsored Links
  #2  
Old 02-17-06, 09:41 AM
Michael's Avatar
Member
Join Date: Nov 2005
Posts: 56
I have a 1996 Taurus and had the door locks, radio and wipers act up. It turned out to be the MLPS that is mounted on top of the trans. It is the switch that is under the arm that the shift cable is connected to. Changed the switch and all is well. Check out www.rockauto.com good parts and prices.
 
  #3  
Old 02-17-06, 05:46 PM
ASEPartsman
Visiting Guest
Posts: n/a
It sounds like a G.E.M. module. These are mounted under the dashboard and the Taurus had a problem with water leaking in there and the module going bad.
 
  #4  
Old 02-17-06, 09:00 PM
Member
Join Date: Feb 2006
Posts: 361
Originally Posted by ASEPartsman
It sounds like a G.E.M. module. These are mounted under the dashboard and the Taurus had a problem with water leaking in there and the module going bad.
Yes Mercury Sable hes the same deal.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'