84 lincoln towncar

Reply

  #1  
Old 03-10-06, 06:15 PM
john angone's Avatar
Member
Thread Starter
Join Date: Feb 2006
Location: Chicago
Posts: 22
Question 84 lincoln towncar

my towncar has around 66,000 orginal miles. my problem is, i can drive my car for 25 minutes, at all different speeds, then when i start to slow down, in order to stop, it starts to run rough and sputtery. I have to go into nuetral and rev the enigine a little to keep it from dying at every stop sign. When i finally get home and shut her down, wait 5 minutes, the car runs fine until the 25 minutes is up. This also does not even happen all the time some days she fine. I've tried the normal tune-up stuff, but need some help.
 
Sponsored Links
  #2  
Old 03-10-06, 06:33 PM
Member
Join Date: Dec 2001
Posts: 2,538
might check the egr valve may be sticking or slow to close causing the engine to run rough or even die when coming to a stop, you could just remove the vacum line from the egr valve and drive it for a while to see how it does if it idles ok with the vacum line disconnected you could try cleaning the egr valve before replacing it.
 
  #3  
Old 03-10-06, 07:59 PM
Member
Join Date: Feb 2006
Posts: 361
When was the last time the inside of the distribitor was tune up.allso pcv valve.Check carb for flooding. (This is juist my opinion.)
 
  #4  
Old 03-15-06, 09:53 AM
john angone's Avatar
Member
Thread Starter
Join Date: Feb 2006
Location: Chicago
Posts: 22
thanks

disconnected that EGR, never ran better!
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes