"Volt" light came on and I lost power steering


  #1  
Old 04-12-06, 11:36 AM
A
Member
Thread Starter
Join Date: Apr 2006
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
"Volt" light came on and I lost power steering

Well, the title pretty much sums up my problem. I drive a 1998 Buick Le Sabre. It's got a V6 and automatic transmission. The car has about 177,000 miles on it right now and I do a lot of driving - probably about 2500 miles a month.

I was driving down the road a few minutes ago, noticed that the "Volt" light came on, with a picture indicating the battery, and I lost power steering and couldn't accelerate. I pulled over, turned the car off, and turned it back on and it ran fine - no light and no trouble.

Could this mean my alternator's going out or maybe my battery's bad?
 
  #2  
Old 04-12-06, 11:42 AM
mattison's Avatar
Member
Join Date: Mar 2003
Location: Cinti, OH
Posts: 5,547
Likes: 0
Received 0 Likes on 0 Posts
Are you sure it didn't just stall ?? With all that you lost it sounds like it quit running on you.
 
  #3  
Old 04-12-06, 11:44 AM
A
Member
Thread Starter
Join Date: Apr 2006
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
It may have - what happens in a stall? I don't have a lot of experience working on my own car so please be gentle.
 
  #4  
Old 04-12-06, 12:39 PM
G
Member
Join Date: Oct 2002
Location: Hamilton County, Ohio
Posts: 4,295
Likes: 0
Received 2 Likes on 2 Posts
You pretty much answered your own question. about what happens. The real question is why did it happen. Possibly you had a momentary loss of power thru the ignition switch. Try jiggling the key with the engine running. If you have numerous keys on the key ring, it could have shut off power. The actual switch is under the dash, on the steering column. It is controlled by a rod from the key, thru the column, to the switch. The actual switch could also have a loose wire or be slightly out of adjustment.
 
  #5  
Old 04-12-06, 05:33 PM
B
Member
Join Date: Aug 2003
Location: Barre,Vermont
Posts: 472
Likes: 0
Received 0 Likes on 0 Posts
It does sound like it stalled, and also a diagnostic trouble code may have set. You might want to have the car checked for these.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: