transmission


  #1  
Old 04-15-06, 10:26 AM
B
Member
Thread Starter
Join Date: Apr 2006
Posts: 14
Likes: 0
Received 0 Likes on 0 Posts
transmission

Hello everybody,
this is my first time and I am not a mechanic,so if I ask anoid ( stupid ) question, please forgive me !! Thanks.

I have 1994 Old, Achiva,3.1 L, 6 Cyl,rebuild Trans( 3 years ago )
with 410,000 Kms !!! yes it runs preety good, last week I have done front break job, new pads, did fuel injection clean, I did because.......
last month when I go above 50 mph car hesitate to go ,once I give full gas it will hesitate but it will go above 60,70, etc but at the point of 50 mph this is problem,
mechanic suggested that might be torqconvter problem, and he suggested that there is some kind of special Oil comes that you pour in trans and it might resolve,
Now I need help in this

what couls be the problem ?
How can it be fix ? without changing convertor !!
what could be the name of that oil?

Some of you might say "junk it " but hey nobody is going to give me $200,and it gives me good service !!

I will appreciate any help

Thanks

I am in Houston, I dorve this car from Canada !! no problem !!
 
  #2  
Old 04-15-06, 10:42 AM
S
Member
Join Date: Jan 2005
Posts: 207
Likes: 0
Received 0 Likes on 0 Posts
Sounds like an engine problem, start by replacing the fuel filter.
 
  #3  
Old 04-15-06, 10:47 AM
B
Member
Thread Starter
Join Date: Apr 2006
Posts: 14
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by slls
Sounds like an engine problem, start by replacing the fuel filter.
Thaks
I will try that
 
  #4  
Old 04-15-06, 04:17 PM
B
Member
Thread Starter
Join Date: Apr 2006
Posts: 14
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by slls
Sounds like an engine problem, start by replacing the fuel filter.
I just got my car back,
I did front brake
- Fuel injection clean up and also as you suggested, replaced fuel filter

Well now car runs very good, no vibration, Thanks
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: