95 Mercury Marquis - No hazard flashers.

Reply

  #1  
Old 04-30-06, 01:36 PM
New Member
Thread Starter
Join Date: Apr 2006
Posts: 2
95 Mercury Marquis - No hazard flashers.

As the title says the hazard flashers on a 95 Merc Marquis don't work.

The turn signals themselves work, the brake lights work so all bulbs are good.

All fuses have been checked both in the fuse panel under the hood and the one under the dash.

Right now the main problem is I can't find the darned hazard warning flasher. The car was bought used in great shape with low miles just no owners manual and I can't find the darned hazard flasher to do any troubleshooting at that point. I'm sure the hazard warning switch is working because with the hazard switch off the stoplights work fine. With the hazard switch in the on position there are no stopligts nor are there any hazard flashers.

Any help will be appreciated.
 
Sponsored Links
  #2  
Old 04-30-06, 02:57 PM
Member
Join Date: Apr 2006
Location: Floriduhhhhh Us of A
Posts: 611
Flashers should be either in the fuse box or tied on or near the steering column..............but I will tell ya..........The #1 problem when it comes to Fords is the infamous "Multi Function Switch"
 
  #3  
Old 05-01-06, 10:05 AM
New Member
Thread Starter
Join Date: Apr 2006
Posts: 2
Reply yo MrWrench

Thanks for your comeback my friend.

The hazard flasher isn't in the fuse box, there's a place in the plastic for a flasher, but there are no terminals which leads me fo think the flasher is located somewhere else.

There is some sheilding/covering or whatever preventing access to the under dash area or steeing column and I can't figure out how to get that off.

Pardon my ignorance but, what is the "multi function switch"? Is that the turn signal switch itself? Does it require the removal of the air bag equipped steering wheel?

Again thank you for your prompt reply.
 
  #4  
Old 05-09-06, 12:52 PM
Member
Join Date: May 2006
Posts: 1
same problem here

I am trying to locate where the flasher unit goes so i can replace it on my wife's car. She needs to have the hazzard lights working before she can get a new inspection sticker

It's already expired so i need an answer ASAP thanks
 
  #5  
Old 05-09-06, 05:24 PM
Join Date: Apr 2006
Posts: 36
Lightbulb

Originally Posted by dafireman
I am trying to locate where the flasher unit goes so i can replace it on my wife's car. She needs to have the hazzard lights working before she can get a new inspection sticker

It's already expired so i need an answer ASAP thanks
try under the dash right near the steering column, if it isnt there look on or around your fuse panel, if not there then it's probably way up under your dash and you'll have to take the dash piece off under the steering column to get to it.
 
  #6  
Old 05-09-06, 05:26 PM
Join Date: Apr 2006
Posts: 36
Lightbulb

Originally Posted by Mr_J
Thanks for your comeback my friend.

The hazard flasher isn't in the fuse box, there's a place in the plastic for a flasher, but there are no terminals which leads me fo think the flasher is located somewhere else.

There is some sheilding/covering or whatever preventing access to the under dash area or steeing column and I can't figure out how to get that off.

Pardon my ignorance but, what is the "multi function switch"? Is that the turn signal switch itself? Does it require the removal of the air bag equipped steering wheel?

Again thank you for your prompt reply.
that is probably where your flasher is(thats where mine was) you have to take that piece of dash off that under the steering column and way up in there somewhere it should be, but it might be somewhere else buti doubt it.
 
  #7  
Old 05-10-06, 04:13 PM
Member
Join Date: Apr 2006
Location: Floriduhhhhh Us of A
Posts: 611
The shrouding on the column splits leaving the steering wheel in place.............two torx head bolts hold the multi function switch to the column........two plugs and you got it licked
 
  #8  
Old 02-19-07, 10:13 AM
Member
Join Date: Feb 2007
Posts: 4
95 Mercury Marquis - No hazard flashers.

Replacing the Multi-function switch fixed the hazard flashers in the dash. Thank you for the great advice.

I am having problems with the high beams, they don't turn on, even if the light is on in the dash. Can someone help, I need to pass the inspection ?
 
  #9  
Old 02-19-07, 06:25 PM
Member
Join Date: Apr 2006
Location: Floriduhhhhh Us of A
Posts: 611
The multi function is new.............so never overlook the obvious..........check the bulbs
 
  #10  
Old 02-20-07, 06:05 AM
Member
Join Date: Feb 2007
Posts: 4
95 Grand Marquis

Originally Posted by wrench47 View Post
The multi function is new.............so never overlook the obvious..........check the bulbs

I have a 95 Crown Victoria, that I drive everyday, so I took out the bulbs from that one, and still nothing, the driving lights work , but the high beams don't ?
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes