Honda CRV front end noise

Reply

  #1  
Old 06-23-06, 05:01 PM
daswede's Avatar
Member
Thread Starter
Join Date: Jul 2003
Location: massachusetts
Posts: 2,218
Received 0 Votes on 0 Posts
Honda CRV front end noise

I have a 2000 Honda CRv that makes a grinding noise when turning left. Any thoughts on what it might be?
Thanks
 
Sponsored Links
  #2  
Old 06-24-06, 04:47 AM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,943
Received 48 Votes on 38 Posts
CV joints don't usually grind, they click; but noises while turning often point that direction. Check your front brake pads for wear also.
 
  #3  
Old 06-24-06, 05:39 AM
nap's Avatar
nap
nap is offline
New Member
Join Date: May 2006
Location: north
Posts: 4,163
Received 1 Vote on 1 Post
I was thinking possible wheel bearing problem. The thing with wheel bearings gone bad is that they usually make some noise while going straight line as well, just worse when turning (more load on them)


I have seen strange things such as calipers coming loose causing odd noises (sometimes grinding) or had brakes in general do odd things.

Pull the wheel where the sound seems to me eminating from and look fro wear marks. Check the brake pads as well while there.
 
  #4  
Old 06-24-06, 06:33 AM
daswede's Avatar
Member
Thread Starter
Join Date: Jul 2003
Location: massachusetts
Posts: 2,218
Received 0 Votes on 0 Posts
thanks everyone. It's raining here ,so i'm off to the garage. Your suggestions are appreciated.
 
  #5  
Old 06-24-06, 08:37 AM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,943
Received 48 Votes on 38 Posts
Post back what you find & fix, swede.
 
  #6  
Old 06-24-06, 11:09 AM
daswede's Avatar
Member
Thread Starter
Join Date: Jul 2003
Location: massachusetts
Posts: 2,218
Received 0 Votes on 0 Posts
Sure will!
 
  #7  
Old 06-26-06, 10:56 AM
daswede's Avatar
Member
Thread Starter
Join Date: Jul 2003
Location: massachusetts
Posts: 2,218
Received 0 Votes on 0 Posts
update:

Front brakes and rotors were the culprit. tech. checked wheel bearings and back brakes,and they were good.
Thanks again
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: