95 Saturn Help

Reply

  #1  
Old 07-10-06, 11:45 AM
Member
Thread Starter
Join Date: Jul 2006
Posts: 4
Question 95 Saturn Help

I have a 95 Saturn SL/1. Replaced plugs and air flter. Car surges when accelerating or under load (i.e. AC on). Possibliities - Oxygen sensors or throttle sensor. thoughts?
 
Sponsored Links
  #2  
Old 07-10-06, 11:54 AM
Banned. Rule And/Or Policy Violation
Join Date: Jul 2006
Posts: 263
possible mas, fuel pressure regulator to don't forget
 
  #3  
Old 07-10-06, 09:34 PM
davzack's Avatar
Member
Join Date: Jun 2006
Posts: 304
Is the check engine light on?
 
  #4  
Old 07-12-06, 07:09 AM
Member
Thread Starter
Join Date: Jul 2006
Posts: 4
95 Saturn Help

the check Engine light does not come on. Ithe care runs fine when first started. after warming up, it starts to surge. when accelerationg, the car does not seem to get any power. , it just revs up. whe the AC is on, the car will idle rough.
 
  #5  
Old 07-12-06, 09:07 AM
Member
Join Date: Sep 2004
Posts: 238
start with the simple stuff

Did you have this problem before you changed the plugs and filter?
if yes-What did the plugs look like? Did the all look about the same? Write back
If no-make sure intake air duct is on tight and has no cracks or holes and all smaller hoses are ok too-make sure plug wires are good, on tight and on the right plugs

it sounds like your fast idle on start-up is masking your problem
 
  #6  
Old 07-12-06, 09:42 AM
Member
Thread Starter
Join Date: Jul 2006
Posts: 4
The problem existed before chaging pluga and filter. That's why I made the changes. The old plugs were worn, did not look too bad except for the wear. Gapping was probly off due to the wear and tear.
 
  #7  
Old 07-17-06, 07:51 AM
Member
Thread Starter
Join Date: Jul 2006
Posts: 4
Problem fixed. It was the spark plug wires.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes