1997 Toyota Camry running rough

Reply

  #1  
Old 07-12-06, 04:16 PM
Member
Thread Starter
Join Date: Jul 2006
Posts: 4
1997 Toyota Camry running rough

I was driving along and my car started sputtering and not running smooth at all. This happened about 3 or 4 months ago, but new spark plugs and wires made it OK. What could be wrong with it now. Surely, the plugs haven't gone bad already. Any advice is greatly appreciated. Thanks
 
Sponsored Links
  #2  
Old 07-12-06, 05:45 PM
DaVeBoy's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Mar 2006
Posts: 1,665
How did the plugs look THEN? Maybe the same thing is happening, such as maybe the plutgs are getting all carboned up. When that happens, the current in the plug may not spark, but simply follow the carbon to ground. I'd pull some plugs and have a look, for starters...seeing that you cured it the last time.
 
  #3  
Old 07-12-06, 06:14 PM
Member
Thread Starter
Join Date: Jul 2006
Posts: 4
The spark plugs were in bad shape before. They were all burnt looking.
 
  #4  
Old 07-13-06, 06:13 PM
Member
Thread Starter
Join Date: Jul 2006
Posts: 4
I had the fuel filter replaced. Checked spark plugs and wires. They were fine. Runs a little better, but not like it did. Maybe I got some bad gas. I'm going to run it out. fill back up, and use some type of fuel treatment. Hopefully that will do the trick. Can anyone add anything more that I can try. Always appreciated. Thanks DaVeBoy.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'