1989 Corvette Coup overheats in slow traffic

Reply

  #1  
Old 07-14-06, 10:38 AM
Member
Thread Starter
Join Date: Jul 2006
Posts: 1
Unhappy 1989 Corvette Coup overheats in slow traffic

I have new radiator, thermostat (2), 10 bladed front fan, rear fan is working, new upper and lower hoses from radiator, yet if ambient air is above 80 I can not run air conditioner with out reaching 240+ in slow traffic. Block check was negative no mix of coolant & oil. Compression is 145 to 160 all around. I know vettes run hot, but not this hot. Can anyone please offer a sloution? Thanks.
 
Sponsored Links
  #2  
Old 07-14-06, 11:53 AM
Member
Join Date: Dec 2005
Posts: 190
I think the a/c condensor is in front of the radiator on a C4, are you sure the condensor is clear....they can pick up a lot of road debris and clog up pretty thoroughly which can lead to overheating.
 
  #3  
Old 07-14-06, 01:42 PM
Banned. Rule And/Or Policy Violation
Join Date: Jul 2006
Posts: 263
Originally Posted by lhewitt
I think the a/c condensor is in front of the radiator on a C4, are you sure the condensor is clear....they can pick up a lot of road debris and clog up pretty thoroughly which can lead to overheating.
Tune port right.
Exactly what he said that car grabs its cooling air from only few small spots. Is that one an electric fan, electric and mechanical. they went through so many changes on the c4 I don't even pay attention to what varied from year to year. And does it come on right away when you turn the A/C on and then off when you turn it off.

Also vettes don't run hot, but the passenger compartments always get very hot.

You replace the radiator cap to along with the radiator, that little cap can make a difference believe it or not.
 

Last edited by snuckers99; 07-14-06 at 01:58 PM.
  #4  
Old 07-14-06, 04:35 PM
Member
Join Date: Jun 2006
Location: St. Louis
Posts: 2,338
Try a new temp guage if only a temporary one, I had a 86 Astro that would go very hot during any type of warm humid weather after checking it out I found it was a problem in the electrical system/factory guage so rather than rip out the dash I learned to live with it. Have a nice day. Geo
 
  #5  
Old 07-14-06, 06:59 PM
Member
Join Date: Aug 2003
Location: Cape Cod
Posts: 4,320
A weak or failing water pump would make the engine run hot at idle, but not at speed
 
  #6  
Old 07-14-06, 08:01 PM
Member
Join Date: Dec 2001
Posts: 2,538
is the engine original or has it been rebuilt or replaced with a rebuilt?
does the fan cycle on and off when idling and the a/c off?
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 06:40 PM.