02 Century losing coolant somewhere

Reply

  #1  
Old 07-22-06, 10:40 AM
Member
Thread Starter
Join Date: Jan 2002
Location: United States
Posts: 44
02 Century losing coolant somewhere

I had my car in 3 months ago cause when I had my oil change they said the coolant was low. My mechanic flushed the radiator and replaced a part (forgot what part).

The a/c works fine. Sometimes a funny smell permiates when I turn it on though. My temp gauge will go up to 1/2 way mark (not overheating red mark) but normally than it should be when I'm just at an idle. (ie. bank drive thru)

Just had oil changed again today. They said the coolant was low. (I had just put some in about 2 weeks ago). There is nothing on the ground so I do not know where it is going to?
Can anyone give me some guidance as to what the problem may be?

I commute about 30 miles to work each day and need to have a dependable vehicle. Thank you so very much!
 
Sponsored Links
  #2  
Old 07-22-06, 11:16 AM
pgtek's Avatar
Member
Join Date: Oct 2004
Location: north Carolina
Posts: 1,391
Hi
go to your garage and ask the mechanic to pressure test your radiator.
he will be able to see where the leak is
also test the radiator cap
 
  #3  
Old 07-22-06, 03:39 PM
DaVeBoy's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Mar 2006
Posts: 1,665
Do you know what hot antifreeze smells like? Could that be your funny smell? Maybe your heater core has a slight leak and is evaporating most the anti-freeze as it runs out, and you get the smell.

Like the suggestion above; a garage should be able to put on this test gauge to see if gases are getting in your anti-freeze -= blown head gasket.

And don't some cars circulate coolant under the carb, and maybe it is entering the intake?

Check under your water pump to be sure that there is no sign of leakage there as you could have some condition where the coolant wants to get spun out only when it is driving down the road.
 
  #4  
Old 09-05-06, 09:24 PM
Member
Join Date: Sep 2006
Posts: 23
3800

lower intake gkt leaking. GM dealers have all the parts in a nice little kit.
 
  #5  
Old 09-05-06, 09:31 PM
Member
Join Date: Sep 2005
Location: Winnipeg
Posts: 57
Wink

no we don't...but remember he said no external leak...pressure test and get a GOOD mechanic to check it out

...not some backyard mechanic...or midas...!
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'