2004 taurus engine light.....

Reply

  #1  
Old 08-02-06, 09:53 AM
Member
Thread Starter
Join Date: Jul 2002
Location: wisconsin
Posts: 140
2004 taurus engine light.....

Replaced fuel filter this past weekend. Tapped the fuel shut off in the trunk, started the car and ran till dead, replaced filter, reset switch in trunk, primed pump, and started car.

Everything is good except 2 days later, the engine light came on at 68,500 miles. It hasent gone off yet and I have driven back and forth to work a couple times since(55 miles each way)

Is this purely coincidence? or did I trip the light by doing something wrong?


thankls!
 
Sponsored Links
  #2  
Old 08-02-06, 12:27 PM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,517
Sounds coincidental. Any chance you gassed up and didn't get the cap on tight? Stop by an Auto Zone and they can read it for you to see what's up.
 
  #3  
Old 08-02-06, 02:39 PM
Member
Thread Starter
Join Date: Jul 2002
Location: wisconsin
Posts: 140
Originally Posted by the_tow_guy
Any chance you gassed up and didn't get the cap on tight? Stop by an Auto Zone and they can read it for you to see what's up.
separate light for the cap but I checked that yesterday just incase and didnt go off.... forgot about autozone scanning things. I guess I will have to swing by there. Thanks!
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'