2000 Voyager Oil Light Indicator

Reply

  #1  
Old 08-04-06, 06:08 PM
Member
Thread Starter
Join Date: Aug 2006
Posts: 1
2000 Voyager Oil Light Indicator

The oil light indicator along with a rather anoying alarm keeps going on while vehicle comes to idle. Removed valve cover and oil is pumping strong. Replaced oil sending unit and everything was back to normal for a couple of months. All of a sudden the problem started all over again. The engine isn't knocking at all which leads me to believe it's not a pressure problem. BTW, the van only has 60k miles.

Any advice would be much appreciated!
 
Sponsored Links
  #2  
Old 08-04-06, 07:05 PM
Former Member's Avatar
Member
Join Date: May 2006
Location: US
Posts: 782
Awh you have discovered why when you cruise thru your local auto scrap yard that there is a very long row of rather nice looking dodge/plymouth vans all parked very neatly ready to roll except for their crap engines.
 
  #3  
Old 08-04-06, 07:49 PM
Member
Join Date: Dec 2001
Posts: 2,538
you need to check oil pressure with a mechanical guage and get the engine up to operating temperature and see what it reads at idle speed in gear, could have low oil pressure at idle and not make any engine noise even if you only had 5 psi of oil pressure at idle.
after checking it manually you will know whether you have a problem with the oil pump or engine, or an electrical problem with the sending unit or warning circuit.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'