2000 mitsubishi galant acceleration problem

Reply

  #1  
Old 08-25-06, 07:49 PM
Member
Thread Starter
Join Date: Aug 2006
Posts: 1
2000 mitsubishi galant acceleration problem

Hello guys , I have 2000 mitsubishi galant and the car has a problem with the acceleration, it feels like the car start directly from second gear instead of first .The check engine light is on end the trouble code is 0760 which means Solenoid 2 electrical malfunction . I went to AAMCO and they said that the transmission has to be rebuild, so i decided to change it with an used one. But after that the problems remain absolutely the same. Please help
 
Sponsored Links
  #2  
Old 08-26-06, 01:31 PM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,513
Not trying to second guess the local tranny guys, but going straight to "rebuild" instead of simply replacing the defective solenoid (or fixing the associated wiring) sounds a little drastic. Some tranny shops prefer to sell rebuilding over repairs because it it more profitable. Shift solenoid failures are fairly common (happend on wife's last Camry) & pretty easy/cheap to fix. Problem with using a used one is that it's quite possible that the shift solenoids are problematic and it might be a common failure. I would research the shift solenoid(s) and see how hard/expensive it/they are to replace (it probably has two) and go from there.

You didn't mention how many miles on the car.
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 06:19 AM.