Fan control relay melting (95 escort)

Reply

  #1  
Old 08-28-06, 09:18 PM
Sparky661's Avatar
Member
Thread Starter
Join Date: Aug 2006
Location: Palmdale
Posts: 3
Angry Fan control relay melting (95 escort)

hello everyone i have an unusual situation on my 95 ford escort wagon my fan control relay keeps melting down every 4 or 5 months im on my 3rd one in a year and a half owning it this problem started not to long ago and its driving me nuts get off work a/c wont work fan dosnt come on gets hot driving it home it sucks happened today lucky i had a few spares in my junk drawer any insight to this problem? fan going bad? sensors? please help! this is driving me crazy thanks
 
Sponsored Links
  #2  
Old 08-29-06, 02:38 AM
New guy's Avatar
Member
Join Date: Feb 2005
Posts: 435
I have no experience with it but, at first I'd make sure that it's correct Ampereage on the replaced relay that you put on and all connection at the relay are clean and tight.
 
  #3  
Old 08-29-06, 04:00 AM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,525
Wild guess - Possibly the fan motor is slowly failing and sucking up a lot of extra amps. Otherwise a bad wire or connection somewhere as New Guy suggests.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'