89 Isuzu Pickup Loping Idle

Reply

  #1  
Old 09-12-06, 11:57 AM
Member
Thread Starter
Join Date: Jun 2006
Posts: 20
Received 0 Votes on 0 Posts
89 Isuzu Pickup Loping Idle

I recently had my fuel pump replaced and the truck ran good. After 3 weeks of running excellent the trucks idle is very low and rough. I checked the fuel filter and tried cleaning the carburetor but could not find the problem. Any suggestions? Thank you for your help.

1989 Isuzu pickup 2.3L engine
 
Sponsored Links
  #2  
Old 09-13-06, 04:35 AM
Join Date: Sep 2006
Posts: 9
Received 0 Votes on 0 Posts
Talking lope

Unfortunately on older vehicles you replace a part to revitalize an aging system and the older parts of the system can't keep up. Assuming your ignition and timing system are properly maintained you're left with emissions. Your EGR valve is fairly easy to clean. Your idle speed stabilizer is a part which tends to fail on 80 model vehicles that have their pumps changed. There is also the Ide Air Control valve or IAC. You also have the throttle positioning sensor which can cause this. Assuming your timing is correct and your plugs, cap , rotor and wires are all functioning correctly. I would check all of these first then go to the fuel pressure regulator and injectors.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description: