stalls when braking

Reply

  #1  
Old 10-17-06, 06:54 PM
Member
Thread Starter
Join Date: Oct 2006
Posts: 7
Unhappy stalls when braking

we have a 94 Olds Cutlas that starts,and will go however I am afraid to drive it as it will stall it seems when ever I put my foot on the brake for stop signs red lights ect.It will restart with a bit of coaxing but not worth the stress to drive it as is.Any help will be appreciated. akjoha
 
Sponsored Links
  #2  
Old 10-17-06, 08:43 PM
HotxxxxxxxOKC's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2006
Location: USA
Posts: 8,044
Sounds like a vacuum leak. If you got a bad vacuum hose, your brakes will starve the motor of the vacuum so you can stop. The brakes are a big part of your vacuum system. It's a safety thing. Inspect all your hoses for crackes, bulches, etc. Hoses should be fairly soft and not stiff.
 
  #3  
Old 10-17-06, 09:23 PM
Member
Join Date: Dec 2001
Location: nc
Posts: 616
Could also be a clogged pcv valve (easy and cheap to replace) or a dirty egr valve among other things. Check the hoses 1st.
 
  #4  
Old 10-18-06, 01:02 PM
Member
Thread Starter
Join Date: Oct 2006
Posts: 7
Red face

thank you for your response about the olds stalling; I too first suspected the vacume hose as remember my sons Dodge Dart did that only the hose would come off completely and would keep putting it back on.Being much older , female, and cars are so different today I will try and find a pic some where of where these things are located and have a go at it.Thank you,akjoha
 
  #5  
Old 10-18-06, 02:34 PM
Member
Join Date: Apr 2003
Posts: 174
How about a bad TCC? Is this a 3.3? If it is, look on the tranny for a blue connector, unplug it.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'