stalls when braking

Reply

  #1  
Old 10-17-06, 07:54 PM
A
Member
Thread Starter
Join Date: Oct 2006
Posts: 7
Received 0 Votes on 0 Posts
Unhappy stalls when braking

we have a 94 Olds Cutlas that starts,and will go however I am afraid to drive it as it will stall it seems when ever I put my foot on the brake for stop signs red lights ect.It will restart with a bit of coaxing but not worth the stress to drive it as is.Any help will be appreciated. akjoha
 
  #2  
Old 10-17-06, 09:43 PM
HotxxxxxxxOKC's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2006
Location: USA
Posts: 8,034
Received 0 Votes on 0 Posts
Sounds like a vacuum leak. If you got a bad vacuum hose, your brakes will starve the motor of the vacuum so you can stop. The brakes are a big part of your vacuum system. It's a safety thing. Inspect all your hoses for crackes, bulches, etc. Hoses should be fairly soft and not stiff.
 
  #3  
Old 10-17-06, 10:23 PM
J
Member
Join Date: Dec 2001
Location: nc
Posts: 616
Received 0 Votes on 0 Posts
Could also be a clogged pcv valve (easy and cheap to replace) or a dirty egr valve among other things. Check the hoses 1st.
 
  #4  
Old 10-18-06, 02:02 PM
A
Member
Thread Starter
Join Date: Oct 2006
Posts: 7
Received 0 Votes on 0 Posts
Red face

thank you for your response about the olds stalling; I too first suspected the vacume hose as remember my sons Dodge Dart did that only the hose would come off completely and would keep putting it back on.Being much older , female, and cars are so different today I will try and find a pic some where of where these things are located and have a go at it.Thank you,akjoha
 
  #5  
Old 10-18-06, 03:34 PM
C
Member
Join Date: Apr 2003
Posts: 174
Received 0 Votes on 0 Posts
How about a bad TCC? Is this a 3.3? If it is, look on the tranny for a blue connector, unplug it.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: