90 Regal signal woes

Reply

  #1  
Old 11-23-06, 08:26 AM
Member
Thread Starter
Join Date: Nov 2006
Posts: 1
Angry 90 Regal signal woes

The right rear turn signal in my 1990 Buick Regal Custom is having issues. The fuse, flashers, and bulbs are all sound. The hazards work. The front right signal is fine. Therefore I have to assume it's a short in the wiring.

The actual problem is not only that the signal doesn't work, but rather that the entire right rear light panel goes dead when I hit the right signal. The tail and brake lights both go out for as long as the signal's on.

Is there anywhere I can find a wiring harness map online? The libraries are, of course, closed for the holiday, so I can't get a Chilton's or anything.

Thanks!
 
Sponsored Links
  #2  
Old 11-23-06, 09:47 AM
HotxxxxxxxOKC's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2006
Location: USA
Posts: 8,044
I would definetly pull that whole light assembly out to check the wiring. Check and make sure your groud wires are all good to go. Here's a wiring diagram for your car, hopefully it helps.

http://www.autozone.com/servlet/UiBroker?ForwardPage=/az/cds/en_us/0900823d/80/0e/da/79/0900823d800eda79.jsp
 
  #3  
Old 11-23-06, 09:58 AM
Member
Join Date: Nov 2006
Location: USA
Posts: 1,342
I had a similar dilemma and, after lots of diagnostic time, it turned out to be a ground. Good luck. That diagram HotinOKC gave you should help.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'