1990 GMC Safari

Reply

  #1  
Old 12-11-06, 07:21 AM
Member
Thread Starter
Join Date: Oct 2002
Location: Niagara Region
Posts: 35
1990 GMC Safari

The heater on my Safari stopped working. So I talked to the guy I bought it from and he said that he would replace the Heater/AC switch and it would work for him. I replaced it and it still doesn't work. I checked the fuse of course and it's still good. I heard that there is another fuse under the hood?
If anyone could help it will be really appreciated.
Thanks
 
Sponsored Links
  #2  
Old 12-11-06, 09:02 AM
HotxxxxxxxOKC's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2006
Location: USA
Posts: 8,044
What is the problem here, no fan? no heat? no air flow?

Have you checked the resistor/motor yet?
 
  #3  
Old 12-11-06, 12:30 PM
Member
Thread Starter
Join Date: Oct 2002
Location: Niagara Region
Posts: 35
when i turn the heat on there's no air coming out of the vents at all..
Is there a way to test to see if the motor is shot?

Thanks
 
  #4  
Old 12-11-06, 01:56 PM
Member
Thread Starter
Join Date: Oct 2002
Location: Niagara Region
Posts: 35
i got it fixed......one of the wires in the harness was not making a connection with the contact on the switch
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 02:34 AM.