Engine runs cold

Reply

  #1  
Old 12-22-06, 12:37 PM
michaeljp86's Avatar
Member
Thread Starter
Join Date: May 2005
Location: USA
Posts: 478
Question Engine runs cold

I have a '92 gmc jimmy and it wont get up to temp. I drove brobably about 100 miles today and it would stay at about 110deg. Sometimes it would get up to 150. It always stays at 200 weather its -20 or 98deg out. Is the thermostat not closing?
 
Sponsored Links
  #2  
Old 12-22-06, 02:14 PM
Member
Join Date: Dec 2001
Posts: 2,538
there is a good chance the thermostat is not closing if you dont have much heat or if it takes a long time to get any heat out of the heater would probably try anew thermostat, if your heater works normal it could be the sending unit or guage actually not giving an accurate temperature.
 
  #3  
Old 12-22-06, 04:04 PM
Member
Join Date: Oct 2006
Location: Wilmington
Posts: 4,219
As suggested above, check the actual water temp. It could be a bad thermostat, or a bad temp gauge or sender.
 
  #4  
Old 12-22-06, 07:43 PM
michaeljp86's Avatar
Member
Thread Starter
Join Date: May 2005
Location: USA
Posts: 478
I replaced the temp sensor a few weeks back because the guage wasnt working and this fixed it. I got a new thermostate, it was only 6 bucks and looks easy to change.
 
  #5  
Old 12-23-06, 04:15 AM
Member
Join Date: Oct 2006
Location: Wilmington
Posts: 4,219
CHECK THE ACTUAL TEMP. Modern cars need to run at about 200 deg, require a 195 thermostat.
 
  #6  
Old 12-23-06, 09:49 AM
Member
Join Date: Oct 2000
Location: Livonia, Michigan
Posts: 923
First, check the temperature of the upper radiator hose with your "calibrated hand". If you can read the engine codes, see if you have a "cold engine" code.

You may have gotten a bad thermostat. I don't like the ones with a check valve for that reason -- had a bad experience with one.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes