1996 Pontiac Sunfire-horn relay and rear hazards

Reply

  #1  
Old 12-30-06, 12:53 PM
Member
Thread Starter
Join Date: Jul 2006
Posts: 5
Received 0 Votes on 0 Posts
Exclamation 1996 Pontiac Sunfire-horn relay and rear hazards

The horn doesn't work when the horn button is pushed but the relay clicks and can be heard somewhere under the dash on the passanger side. Disconnecting and reconnecting the battery causes the alarm to sound so the horn itself is good. When the hazards are activated the rear hazards don't work, as well. However, the rear turn signals do work. I have looked the horn relay location up in the haynes Manual and it indicates it is located in the convenience center under the dash on the driver side but when this panel is removed I don't see anything that looks like it houses relays. I would appreciate any help on this very much. I need to get these things fixed so I can pass my state's safety inspection which is due in 2 days. Thanks!!
 
Sponsored Links
  #2  
Old 12-30-06, 01:23 PM
Member
Join Date: Apr 2006
Location: Floriduhhhhh Us of A
Posts: 611
Received 0 Votes on 0 Posts
I'd be willing to bet your whole problem is tied up in the alarm wiring from what you've described
 
  #3  
Old 12-30-06, 01:48 PM
Member
Thread Starter
Join Date: Jul 2006
Posts: 5
Received 0 Votes on 0 Posts
It's interesting you say that b/c I had to just turn the alarm off for good about 4 years ago cuz it would go off on it's own for no reason. I do believe you're advice was correct cuz after taking a closer look the alarm system is intregrated into the electrical, horn and lights wiring of the car. I had the alarm put in when I bought the car brand new a little more than ten years ago. The place that did it isn't even in business anymore. I have no wiring diagram for the alarm system. Any suggestions?
 
  #4  
Old 12-30-06, 02:30 PM
Member
Join Date: Apr 2006
Location: Floriduhhhhh Us of A
Posts: 611
Received 0 Votes on 0 Posts
All I can say is try to locate the alarm module.........Remove it wire by wire and reconnect anything they cut along the way..........Then hope for the best
 
  #5  
Old 12-30-06, 03:43 PM
Member
Thread Starter
Join Date: Jul 2006
Posts: 5
Received 0 Votes on 0 Posts
Okay... thanks so much. I did find a relay that the alarm, hazards and horn run through. The alarm guys who installed the system seem to have done a fairly sloppy job. Anyway, the new relay didn't solve the problem. I guess I'll look into your suggestion. Thank you again. I'll post back any solution I may find.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description: