1995 Chevy Blazer stalls after about 10-15 M=minutes

Reply

  #1  
Old 01-05-07, 07:04 AM
T
Member
Thread Starter
Join Date: Jan 2007
Posts: 1
Received 0 Votes on 0 Posts
Cool 1995 Chevy Blazer stalls after about 10-15 M=minutes

My 95 Blazer keeps stalling after about 10-15 minutes, Starts fine, runs fine then starts to bog down a little and just die, usually when I'm stopped or slowed down and then hit the gas again. After sitting for about an hour or so, it starts right up and then does the same thing in 10 minutes again. It has a brand new fuel pump anf filter (2nd time in about 3 months). Also has new plugs, wires, Ignition Module and Ignition Coil. I'm stumped here, the Cap and Rotor are also fairly new within the last 6 months and there is no moisture in there either. Any help is greatly Appreciated.
 

Last edited by tool069c; 01-05-07 at 08:04 AM. Reason: forgot info
Sponsored Links
  #2  
Old 01-05-07, 04:49 PM
M
Member
Join Date: May 2006
Location: Iowa!!!!!
Posts: 4,109
Received 9 Votes on 9 Posts
As soon as it dies, shut off the key and go to the schroeder valve on the fuel rail. Depress it with a ink pen and see if it has any pressure in it. If not, you have a fuel system problem. A possibility would be the pressure regulator.

Another possibility would an OX sensor. Those take about ten to fifteen minutes to heat up until they start signaling the computer.

Hope this helps,

Bob
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: