blower relay went bad

Reply

  #1  
Old 01-22-07, 12:57 PM
Member
Thread Starter
Join Date: Aug 2006
Location: USA
Posts: 204
blower relay went bad

I have that 1991 Chevy corsica. The Problem is that my fan quite (the one that blows heat into the car) The fan works because i tested it with direct power, but but will not kick on from the fan switch inside the car. I was thinking it could be a relay switch. but which relay is it under the hood on the fire wall?

thanks
 
Sponsored Links
  #2  
Old 01-22-07, 02:15 PM
HotxxxxxxxOKC's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2006
Location: USA
Posts: 8,044
Have you checked the Blower motor fuse? It's usually a green 30amp. If that is fine, it may be the resistor which is sometimes located on or near the air box. You may need to check with dealer to find out exactly where.
 
  #3  
Old 01-22-07, 02:29 PM
Member
Thread Starter
Join Date: Aug 2006
Location: USA
Posts: 204
ok, to let everyone know the fuse is good
 
  #4  
Old 01-23-07, 10:45 AM
Member
Join Date: Oct 2000
Location: Livonia, Michigan
Posts: 923
Check the resistor block. I'm assuming your car has one. Both my cars had problems with the resistor block.
 
  #5  
Old 01-23-07, 03:33 PM
Member
Thread Starter
Join Date: Aug 2006
Location: USA
Posts: 204
HotinOKC i could not find the resistor. when you say air box do you mean the area around the fan or the air filter?
 
  #6  
Old 01-23-07, 04:40 PM
HotxxxxxxxOKC's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2006
Location: USA
Posts: 8,044
Near the fan box. The big black box behind your dashboard. You should call dealer or maybe someone else can chime in before you tear anything apart.
 
  #7  
Old 01-23-07, 05:31 PM
Member
Thread Starter
Join Date: Aug 2006
Location: USA
Posts: 204
sorry

oh wait, I think i confussued you. i was trying say that the fan does not turn on at all from the switch in the car. But when i tested to see wheather the fan worked or not i took jumper cables to the fan and it worked but something is wrong in the wiring. i don't think its the resistor because when i go down the road i can feel air come through the vents.

i hoped this cleared up some of it.
 
  #8  
Old 01-24-07, 01:52 AM
Member
Join Date: Nov 2001
Location: North Texas
Posts: 2,345
sit in car

Sit in the car with it not running and key in ACC position and try the blower speeds. The air you feel driving is probbably the air from your flow thru ventelation.
This air comes in as you drive and just passes thru the ducts with no help from motors.
 
  #9  
Old 01-24-07, 12:07 PM
Member
Thread Starter
Join Date: Aug 2006
Location: USA
Posts: 204
i can not hear or feel the fan kick on
 
  #10  
Old 01-25-07, 04:41 PM
Member
Thread Starter
Join Date: Aug 2006
Location: USA
Posts: 204
i just figured out that the relay was bad because part of it was melted. i put a togle switch for temporary thing.
thanks for the help
 
  #11  
Old 06-10-07, 07:46 PM
Member
Thread Starter
Join Date: Aug 2006
Location: USA
Posts: 204
the Relay whent bad again. I bought another new one one bought a new pig tail wireing harness to.
 
  #12  
Old 06-11-07, 06:01 AM
HotxxxxxxxOKC's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2006
Location: USA
Posts: 8,044
You may want to put a fuseable link in that new pigtail just to be safe.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'