1997 buick century coolant light

Reply

  #1  
Old 01-25-07, 06:29 PM
Member
Thread Starter
Join Date: Jan 2007
Posts: 1
Question 1997 buick century coolant light

i recently had water pump replaced,my engine coolant light in dash remains light up,mechanic told me that it would eventually go off but in the past 3 weeks it has not,does this need to be reset?can someone guide me thru this process.i prefer to find out myself before i go complaining to the mechanic.please help
 
Sponsored Links
  #2  
Old 01-25-07, 06:58 PM
Member
Join Date: May 2006
Location: Iowa!!!!!
Posts: 3,670
That light should be fed by water temp sensor specifically for that gauge. A completely different temp sensor would feed the computer.

I would suggest changing the sensor. They aren't that expensive.

Hope this helps,

Bob
 
  #3  
Old 01-26-07, 07:58 AM
Member
Join Date: Jan 2007
Posts: 17
light

sensor should be in the radiator of the level is full and sensor is plugged up wires not damaged replace the sensor
 
  #4  
Old 01-26-07, 05:19 PM
Member
Join Date: Jan 2007
Posts: 43
well so far you are all wrong but thats ok the sensor is in the overflow resevoir on the pass side of the engine compartment you should look and see if it is full and that the radiator is full if so find the sensor and tap on it while the engine is running as long as you can do it safely, also unplug it if the light goes out I would say replace the sensor but the biggest thing is make sure everything is full to the propper level
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 05:52 AM.