2004 pacifica staticky noise on rev up

Reply

  #1  
Old 01-26-07, 04:21 AM
Member
Thread Starter
Join Date: Oct 2006
Posts: 78
Unhappy 2004 pacifica staticky noise on rev up

i was driving on highway and started to get staticky noise. i was able to drive home with no loss of power, no new dashboard warning lights, no engine overheating. the noise is worse with higher rpm. the noise is soft and is present when the car is parked and the engine is idling. it get worse and loud on rev up. opened up the hood and it seems to be coming from behind the engine. sounds like a bad bearing on a moving part or hole in muffler or something else. any ideas before i head to dealership for a diagnostics.
thanks
 
Sponsored Links
  #2  
Old 01-26-07, 04:41 AM
Member
Join Date: Oct 2006
Location: Wilmington
Posts: 4,219
I would think the car is too new to have exhaust problems, but it is possible. There are lots of things on and around an engine that can come loose or make noise, not all are bad. But best to have it checked out.
 
  #3  
Old 01-28-07, 08:21 PM
Member
Join Date: Jan 2007
Location: Ohio
Posts: 50
Check the bottom of the egr they sometimes fall out.
 
  #4  
Old 01-29-07, 05:35 AM
Member
Thread Starter
Join Date: Oct 2006
Posts: 78
it is of rotary in nature.

thanks for the feedback,

the higher the rpm the higher is the frquency. has not had a chance to get under. too cold outside. will post findings when available.
 
  #5  
Old 02-01-07, 11:48 AM
Member
Thread Starter
Join Date: Oct 2006
Posts: 78
you were right about egr

took the car to shop. was told egr need to be replaced. cost including labor, engine light code pull, clearing codes etc ~200 us dollars.

thanks to you all for the support.

thanks for the diagnosis
Originally Posted by pureluck32 View Post
Check the bottom of the egr they sometimes fall out.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes