1987 dodge tranny replacement

Reply

  #1  
Old 02-14-07, 03:25 PM
Member
Thread Starter
Join Date: Feb 2007
Posts: 2
1987 dodge tranny replacement

hello,

lost reverse the other day in my van ..the cable was good... so i took off
the pan ..and everything was messed up ..so i replaced the valve body with another one.. ..after that i got my reverse back but no drive now.
.. so i switched back to my old one same thing.. i do have drive but it has to rev extremly high ..for about a min before it moves a little.

so 2 questions .. what the heck went wrong?

there is only 2 pipes things that go into litle holes i made sure on the last time they were going up ..? is it possible it had a ring of some type.
but that neither the new /used one had it on the other tranny that i notice nor this one.
..
or ./ and..

what other years of transmisions can i put in a 1987 2.2 ..will a 2.6 fit 3.x
will one from a 2.2 car fit?...and what years .. from 1984 -1991 are they all the same tranny?

------------edit.

sorry, its a dodge caravan 1987



thanks
 
Sponsored Links
  #2  
Old 02-14-07, 03:48 PM
HotxxxxxxxOKC's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2006
Location: USA
Posts: 8,044
Sounds like you have a shredded driveshell. Was there alot of shavings on the magnets?
 
  #3  
Old 02-16-07, 08:13 PM
Member
Thread Starter
Join Date: Feb 2007
Posts: 2
Originally Posted by HotinOKC View Post
Sounds like you have a shredded driveshell. Was there alot of shavings on the magnets?

Hi thank you so much for taking time to suggest something..

however no metal shavings on the magnet.. some sludge looking stuff thats about it..

i was going to try to take off the valve body one more time 2morrow and pound in the pipes with a hammer or something heh....and if that doesnt work
try to get another tranny. from the wrecker.. ..

my drive worked good until i took off the valve body.. accept something did happen.. before hand.... i had gone to the front of the van.. to manual shift it ..without the cable on ..still no reverse ..but then it shifted into first went for a small ride.... i tried to shift the shifter lever back down .. but it started to make a grinding sound... but after that i had pushed my van back out where it got stuck..and i still had drive......



Then the next day i took off the pan... the lever part that goes to what i can guess is the park thing... was wedged in that location.
..its a long bar ..with a spring that extends another peice of metal..if that makes any sense to you. .. .


is it possible for me to find the driveshell thing? to see if thats the problem ..is it possible to fix easy ? /not having to take the entire tranny off.
 

Last edited by glenn29; 02-16-07 at 08:24 PM.
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes