supercharger no go

Reply

  #1  
Old 02-22-07, 04:45 PM
Member
Thread Starter
Join Date: Feb 2007
Posts: 1
supercharger no go

i have a 92 thunderbird sc that recently lost it's sc-ness. it happened just after i changed the oil in the supercharger unit. the old oil was pitch black, thin, and smelled like burnt garbage. i syphoned out as much old oil as i could, with a turkey baster( as per the haynes manual) and noticed within two days that every time i kicked it in the guts, it stuttered and shook. violently. the oil level is right, the oil type is right, the oil changer is confused. otherwise, the car runs fine. any ideas? very cool sight, by the way. thanx
 
Sponsored Links
  #2  
Old 02-22-07, 05:38 PM
HotxxxxxxxOKC's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2006
Location: USA
Posts: 8,044
The S/C is probably toast. If the oil smelt burnt, that is a bad. Only option from here would be get S/C rebuilt, or get new if they even have them available anymore.
 
  #3  
Old 02-22-07, 05:40 PM
tonedeaf2000's Avatar
Member
Join Date: Jan 2007
Posts: 13
Talking SC go go gadget

sounds like something happen to the charger does it get up and scoot when you press on the gas? notice the Boost? if it shakes it could be a wire off 1 of the spark plugs sounds silly but under load it would prolly do that and then some im no expert but theres a few cool sites on the web that could help you
ya might try SCCOA a great site and plenty of help i know i own one
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes