94 ranger 4.0

Reply

  #1  
Old 03-13-07, 05:36 PM
Member
Thread Starter
Join Date: Feb 2007
Posts: 11
94 ranger 4.0

battery light comes off and on ( on dash ) also the voltage meter will go low and high at times. it does not matter if my lights are on or off.

had the battery and alternator checked all seem ok running condition

what next????

thanks
gary
 
Sponsored Links
  #2  
Old 03-13-07, 05:41 PM
HotxxxxxxxOKC's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2006
Location: USA
Posts: 8,044
Autozone type testing on the alternator are not that accurate. Get a multimeter and test the battery while engine us running. You should not have below 13volts DC. If you do, you either have a bad battery and/or alternator.
 
  #3  
Old 03-13-07, 06:26 PM
Member
Join Date: Apr 2006
Location: Floriduhhhhh Us of A
Posts: 611
Voltage testing,alone, is not always indicative of a good or bad alternator.............and the LAST thing you want is an intermittent alternator spiking your ECM
 
  #4  
Old 03-14-07, 04:58 AM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,571
Check & clean battery terminal connections before you do anything else. Look for corrosion where battery cables are connected to the terminals; clean/replace as necessary.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes