99 jeep wrangler

Reply

  #1  
Old 03-23-07, 12:48 PM
Member
Thread Starter
Join Date: May 2006
Posts: 80
99 jeep wrangler

My check engine light came on a little while ago while I was driving and my jeep started acting sluggish. It bucked a little bit at first and now isn't idling right. When I push the gas it's not reving like it should. There seems to be a slight delay. Then it acts sluggish. I am about to take it to Auto Zone and have it tested so I will be able to post a number in a few. Any ideas in the meantime of what it could be?

I have a 99 jeep wrangler sport, 82K miles, 4.0 engine. Thanks.
 
Sponsored Links
  #2  
Old 03-23-07, 03:16 PM
HotxxxxxxxOKC's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2006
Location: USA
Posts: 8,044
To many things to guess without the P code.

Cylinder misfires
Bad fuel pump
some sensors among other things.

Get us that code! :-)
 
  #3  
Old 03-25-07, 08:05 AM
Member
Thread Starter
Join Date: May 2006
Posts: 80
fixed it

It was the TPS. I replaced it and all is well.
 
  #4  
Old 03-25-07, 08:27 AM
HotxxxxxxxOKC's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2006
Location: USA
Posts: 8,044
Thanks for posting the results! Glad it's fixed!
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'