1997 mercury Grand Marquis,4.6 v8

Reply

  #1  
Old 03-26-07, 05:23 PM
Member
Thread Starter
Join Date: Dec 2006
Posts: 2
Angry 1997 mercury Grand Marquis,4.6 v8

I just changed the air intake plenum on this 4.6 V8. I gather it is a common occurence with them. I bought a new after market intake with the cast thermostat housing.I changed it because it cracked in the coolant chamber
between the thermostat housing and the other side of plenum across the front. My problem is,i changed evrything over ,throttle body ,sensors ,fuel injectors ,injection rail etc. everything. The car will run but not well.It wants to die when you give it throttle and runs a little rough when you turn on compressor.I reused evrything on the car because all was running well.
Any ideas as to what might need to be done.? Air throttle sensor ?
Did i miss doing something like a readjustment or something. I have a code reader and it doesn't seem to read any bad fault codes

Stumped?
 
Sponsored Links
  #2  
Old 03-27-07, 04:03 AM
Member
Join Date: Oct 2006
Location: Wilmington
Posts: 4,219
That's a lot of stuff to replace and expect to all work without problems. Sounds like you need a scanner that actually gives readouts of each sensor/device. They can be expensive, or take it to your local garage.
 
  #3  
Old 03-27-07, 02:26 PM
Member
Join Date: Jul 2002
Location: corona Ca.
Posts: 471
along with scanning for codes, my first suspect would be a vacuum problem, look for a leak and/or misrouted lines.
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 01:41 AM.