1997 Mercury Sable Dies

Reply

  #1  
Old 04-05-07, 02:09 PM
Member
Thread Starter
Join Date: Apr 2007
Posts: 2
1997 Mercury Sable Dies

I am not sure of the engine. The battery light flickered a few times then stayed on. I parked it, then drove it a few hours later. It drove fine for about 25 mins then the abs light came on, then the fuel light (I had put half a tank earlier) also the wipers were like in slow motion then the airbag light along with a few beeps then the car sputtered and died. I was able to start it up within 10-15 mins, however within 5 mins the same series of events ocurred. It will start but....

Maybe unrelated - intermittently my inside lights will stay on after the doors are shut - could be 1 - 2 shuts, has gone as long as 2 days, has not happened in about a week.

Thanks for any help.
 
Sponsored Links
  #2  
Old 04-05-07, 03:09 PM
HotxxxxxxxOKC's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2006
Location: USA
Posts: 8,044
Sounds like a failing battery and/or alternator.

Have autozone type store test your battery and alternator. Sometimes these free tests are not that accurate, but most of the time they can see if these are bad.
 
  #3  
Old 04-05-07, 03:19 PM
Member
Join Date: Oct 2006
Location: Wilmington
Posts: 4,219
I agree, dying battery or bad/dirty connections. If it runs once it starts, alternator probably is OK. Have it all tested.
 
  #4  
Old 04-05-07, 05:31 PM
Member
Thread Starter
Join Date: Apr 2007
Posts: 2
Thank you. Will clena the connectors and give the test a try.
 
  #5  
Old 04-06-07, 03:26 AM
Member
Join Date: Apr 2007
Posts: 9
Sounds to me like the alternator may be failing, if it starts and runs for a little while then all the lights come on and it dies the alternator doesn't sound like it is charging correctly. With a bad alternator the car will run until the battery cannot support it anymore. Have them both tested.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'