1993 Cad DeVille

Reply

  #1  
Old 05-26-07, 05:37 PM
Member
Thread Starter
Join Date: May 2007
Posts: 3
1993 Cad DeVille

Help!!!! Will not start. No spark. Changed coil, new battery. Looking for wiring diagram or other sources of info. Do not have owners manual. Any suggestions would be appreciated.
 
Sponsored Links
  #2  
Old 05-26-07, 07:39 PM
Member
Join Date: May 2007
Location: barre, washington county
Posts: 4
i had this problem in my 91

you need to replace the ignotion module it is located in the distributor underneath the rotor there will be a rectangular flax black box with 2 screws thats what u need to change
 
  #3  
Old 05-27-07, 06:01 PM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,513
The module isn't a 100% chance of fix, but it would certainly be high on the list.

Also wouldn't hurt to pull codes just in case. It's DIY on you old Caddy:

http://www.troublecodes.net/GM/
 
  #4  
Old 05-28-07, 06:32 AM
Member
Thread Starter
Join Date: May 2007
Posts: 3
1993 cad deville

Tanks for the info.We are going to get another modual.We are doing this without a manual .I guess were trying to beat the manufactures and do the basics .This is my first on this site that i found by accident.Its great info.
Its my fathers cady and Im trying to help him.Thanks again for the tip on the modual.
 
  #5  
Old 05-28-07, 06:45 AM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,513
Don't forget to pull the codes. I had a no-start on my wrecker last year that drove us crazy until we discovered it was a bad temp sender (for the computer); there was a code stored, but we were convinced it was a coil/module/etc.
 
  #6  
Old 06-03-07, 05:51 PM
Member
Thread Starter
Join Date: May 2007
Posts: 3
93 cad deville no start

We did replace modual in dist. and rotor with no luck.We will do cap next.A mechanic told us there is a sensor on the passenger side under wheel that I have never heard of ,except for a speed sensor for ABS which are on all 4 wheels.He said you have to take wheel off to get at it.We havent found a manual yet.I guess we will have to go to alldata.com or go to library.
Cant pull the codes on this car unless you have scanner.This car does not have have Aand B terminals needed to get code counts with out scanner.
 
  #7  
Old 06-03-07, 06:20 PM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,513
Crank sensor could be in that general location; not sure on a Deville.
 
  #8  
Old 06-03-07, 06:27 PM
Member
Join Date: Apr 2006
Location: Floriduhhhhh Us of A
Posts: 611
Test light the ign coil...........First for power TO the coil..........Then for pulse as the engine cranks (By placing the test light on the NEG side of the cooil when cranking, light should flash)..................This sounds more of a ccc kinda set up where the car STARTS on the pick-up in the dist, then switches to computer control after @400RPM...........I'd check the ign coil as I staed firsr before replacing any more parts.......At least THEN you'll know whether the problem is Primary or Secondary
 
  #9  
Old 06-03-07, 06:45 PM
Member
Join Date: Jan 2007
Location: davie & morriston ,
Posts: 15
have u checked if the rotor spins when cranking, tom
 
  #10  
Old 06-03-07, 10:00 PM
Member
Join Date: Dec 2001
Posts: 2,538
first check power to the distributer at pos side of coil then would probably suspect pickup assembly in the distributer if you have no spark, sounds like you have replaced most of the ignition system, coil, rotor,module, you have to remove the distributer to replace the pickup.
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 09:28 AM.