shifting HARD, engine lights, help............

Reply

  #1  
Old 06-09-07, 05:57 PM
Member
Thread Starter
Join Date: Aug 2003
Location: Augusta, GA
Posts: 31
Received 0 Votes on 0 Posts
Question shifting HARD, engine lights, help............

went to start up my 4 cyl 1999 grand am today. Trac off light is on, won't shut off. black out of tailpipe at start up for a minute, and jumping everytime it shifts. it has a sealed tranny, so I have NO IDEA where to start. also service engine light came on. it was on a few weeks ago, but place said it was O2 sensor. but it's back on. this car never ran this rough. I did put injector cleaning in at last fill up, and tank is down to 1/8, but thats all.

Thanks!!
 
Sponsored Links
  #2  
Old 06-09-07, 08:39 PM
HotxxxxxxxOKC's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2006
Location: USA
Posts: 8,044
Received 0 Votes on 0 Posts
Did you replace the O2 sensor? Get the code numbers and report back here.
 
  #3  
Old 06-10-07, 06:17 AM
Member
Join Date: Apr 2006
Location: Floriduhhhhh Us of A
Posts: 611
Received 0 Votes on 0 Posts
You didn't state engine size, but I'm betting a 2.3 or 2.4..........The "Quad 4" engine........The 4 bolts on top of the engine will release the ignition components as a whole.............Invert the top and you will see a rather large coil tower containing both ignition coils. The connector runs to the ign module........Check your plugs and replace as necessary..........and I'll bet if you replace the coil tower, your problems will be over.......Clear the codes and drive vehicle, as a missfire, overtime, will set a whole bunch of codes .........one of which will be O2.....
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description: