92 Achieva oil pressure problem

Reply

  #1  
Old 07-18-07, 10:27 AM
Member
Thread Starter
Join Date: Jul 2007
Posts: 4
92 Achieva oil pressure problem

Hello:
I just purchased a 92 olds achieva 3.3l v6 131k; I have a few problems that I need help with;... for now its my oil pressure;
the car runs fine but the oil gage upon start up goes to 70 and if left to idle after a few minutes it will gradually got down to 40 and the "check oil" lite comes on. Also when driving it will stay at 70 but when you come to a stop it goes down to 40.
Am I doing any damage by driving this way?
What should the optimum driving level be at?

I did get a oil/filter change and that didnt solve the problem.

Any help would greatly be appreciated
thank you
 
Sponsored Links
  #2  
Old 07-18-07, 10:38 AM
HotxxxxxxxOKC's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2006
Location: USA
Posts: 8,044
It could be a faulty oil pressure switch or the oil pump.

I would not drive it to much until you get it looked at. A failing oil pump can cause engine damage.

The light comes on telling you oil pressure has dropped or to high. It may be a clogged oil pickup screen as well.
 
  #3  
Old 07-18-07, 05:39 PM
Member
Join Date: Apr 2003
Posts: 174
On my 93 Grand Am with the same motor, my check oil light was on all the time, it was the sensor in the oil pan, never could find a replacement. If your gauge is correct 40psi at idle seems good to me.
 
  #4  
Old 07-25-07, 07:18 AM
Member
Thread Starter
Join Date: Jul 2007
Posts: 4
thanks......thats what i was thinking

Is 40psi ok to run if it is just at idle
 
  #5  
Old 07-25-07, 09:08 AM
Member
Join Date: May 2006
Location: Iowa!!!!!
Posts: 3,753
40 psi is fine at idle. It will typically go down at idle. If you're running 70/40 you're ok.

Make sure your engine oil level is ok with your dip stick.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes