chevy celebrity 87 2.8l low Coolant light staying on

Reply

  #1  
Old 08-12-07, 03:03 PM
Member
Thread Starter
Join Date: Apr 2006
Posts: 5
chevy celebrity 87 2.8l low Coolant light staying on

I've got a 87 Chevy Celebrity 2.8L model. Every time I crank the car the low coolant light comes on and stays on. The radiator is full with a 50/50 mix. It's got a new thermostat and a new water pump and everything seems to be working fine. I think it may be a faulty sensor somewhere. Any help with this would be much appreciated.
 
Sponsored Links
  #2  
Old 08-12-07, 03:09 PM
HotxxxxxxxOKC's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2006
Location: USA
Posts: 8,044
It does sound like the sensor. This sensor is usually located at the bottom of the coolant reservour. If this light is annoying you, you can unplug the connector plug underneith and the light will go out until you get it replaced.
 
  #3  
Old 08-12-07, 03:19 PM
Member
Thread Starter
Join Date: Apr 2006
Posts: 5
Can that sensor cause any problemes with coolant flow? I just had to do a head gasket replacement because the water pump and half a dozen hoses went out. I don't want it to happen again. So could that sensor cause any trouble?
 
  #4  
Old 08-12-07, 03:36 PM
HotxxxxxxxOKC's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2006
Location: USA
Posts: 8,044
No. The sensor just lets you know when the reservoir is low on coolant. It is common for these to fail, especially if the reservoir has ever ran dry. It's a fairly easy fix.
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 01:11 AM.