1992 Buick Regal GS 2 door

Reply

  #1  
Old 08-22-07, 05:02 PM
Member
Thread Starter
Join Date: Aug 2007
Posts: 2
1992 Buick Regal GS 2 door

My car keeps having problem after problem. I recently went on a road trip for a company I work for. 1000 miles round trip. My 1992 Regal only has about 94,000 miles so it's not a big deal. However, while i was on the trip, about 300 miles into it, my cruise control stopped working. It went off and on throughout the beginning of the trip. Also, the air conditioning through the dash vents was going in and out. My dad does a lot of the simple repairs on my car so he checked the fuses and the.. vacuum hose.. i think... and it was cracked. he replaced the hose and still, nothing has changed. Can anybody please help? I'm sick of my car causing so much stress on my dad. Thank you so much for any help you might have for me.
 
Sponsored Links
  #2  
Old 08-22-07, 05:44 PM
HotxxxxxxxOKC's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2006
Location: USA
Posts: 8,044
I would suspect vacuum issue as well because the cruise control in that year and the a/c vents are controlled by vacuum.

What size motor do you have? 3.8?
 
  #3  
Old 08-23-07, 04:24 PM
Member
Thread Starter
Join Date: Aug 2007
Posts: 2
yes, the motor is a 3.8
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 03:34 AM.