HYUNDAI 1999 ATOZ 1Ltr PROBLEMS

Reply

  #1  
Old 09-11-07, 10:12 PM
Member
Thread Starter
Join Date: Sep 2007
Posts: 2
HYUNDAI 1999 ATOZ 1Ltr PROBLEMS

Hi folks,

I need help urgently

my 1999 Hyundai Atoz has got major probs, it seems to lose virtually all power when taking off it 1st gear from lights or hill starts etc...

I have replaced the spark plugs and the H.T leads, which solved the majority of the problem, I also had the car checked by a diagnostic computer in the dealers which returned no faults.

However the problem seems to be coming back into it


it is very frustrating because I am having to double-clutch to get the car to pick up speed in 1st gear,

A friend has suggested I check the fuel filter?

I believe it under the car somewhere near the tank?

Anybody got any suggestions as to what the problem could be as it is costing me a mjaor headache and a small fortune so far

once the car gets going it it great, just getting it to pick up speed is the problem at the start

Many thanks in advance guys

cheers

Glenn
 
Sponsored Links
  #2  
Old 09-12-07, 03:09 PM
HotxxxxxxxOKC's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2006
Location: USA
Posts: 8,044
I highly doubt a fuel filter but if it hasn't been changed, change it. A bad fuel filter would probably effect the running of the motor. It sounds like a bad clutch problem. When was it all last replaced?
 
  #3  
Old 09-12-07, 05:37 PM
Banned. Rule And/Or Policy Violation
Join Date: May 2007
Location: Wisconsin
Posts: 8,629
Originally Posted by DEPUTYDUKE View Post
I have replaced the spark plugs and the H.T leads, which solved the majority of the problem, .....
However the problem seems to be coming back into it
This part of your quote makes me wonder just exactly HOW much of that problem was solved. You make it sound like what they did sort of helped - and then the problem came back? Do you really believe that what they did the first time helped, or did you sort of convince yourself, due to all the money you spent, and the fact they were pros, that you kinda thought it seemed better. Which is it?

IF you really really think they had it fixed the first time, better have them recheck what they did.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes