99 Intrepid heater fan resistor burns out

Reply

  #1  
Old 10-21-07, 03:21 PM
Member
Thread Starter
Join Date: Jan 2006
Location: Owen Sound Ontario Canada
Posts: 541
Received 0 Votes on 0 Posts
99 Intrepid heater fan resistor burns out

I replaced the resistor block" in my 1999 Chrysler Intrepid and 4 days later it burnt out again.
When they burn out, only high speed for the fan works.
The 3 speeds below that dont work.

I put in a new one when I put one in and the parts guy new exactly what I was talking about.

My question is: Are these cars hard on them resistors or is there a problem in my electrical system that is going to burn these out.

Each one cost $40

Should I ask the parts guy if I can get another one free because the other one only lasted 4 days?

Thanks
 
Sponsored Links
  #2  
Old 10-21-07, 05:32 PM
Member
Join Date: Dec 2001
Posts: 2,538
Received 0 Votes on 0 Posts
it possible the motor may be pulling excessive amps and causing the resistor to fail if all your connections look clean and the resistor doesnt appear to be getting wet would probably replace the fan motor and install a new resistor.
 
  #3  
Old 10-21-07, 07:04 PM
Member
Join Date: Jul 2006
Location: Near Philly
Posts: 559
Received 0 Votes on 0 Posts
Get a new fan motor; it is pulling too many amps. Can order from Autozone much cheaper than dealer's price and other places I shopped. Fit right in.
Good luck!
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description: