Oil light on and foff

Reply

  #1  
Old 12-08-07, 02:52 PM
Member
Thread Starter
Join Date: Nov 2006
Location: Jersey
Posts: 526
Oil light on and foff

I think my '01 Malibu might be kicking the bucket soon.
This week for the first time ever my oil indicator came on then went off and then at least once a day since Monday.

I am due for and oild change but not much over the 3,500 mile mark and i did notice I was down about 1/2 a quart last week.

I've never known it to burn oil and the engine sounds normal.
It's got 180,000 mile on it maybe it's the sender.......mmmm, don't know or maybe it's the pump........mmmmm.
Last time I delt with this kind of problem it was a '67 Skylark, I changed the oil and never got oil pressure again from that point on,........ it was the pump.

Haven't done an oil pressure test yet, maybe I should go there first.

Any suggestions, I'd like to get another 100,000 out of it the body and interior are perfect but I have noticed the trans slipping if I have to nail it from a dead stop otherwise it's fine.

New cars ('07 left overs) are at 0 % intrest for 60 months to......hmmmm?

Any body, any body.........Buhler........Buhler........?
 
Sponsored Links
  #2  
Old 12-08-07, 07:30 PM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,596
Lot of miles on an '01, but I think I would give the sender unit a try; pretty cheap fix if that's it.
 
  #3  
Old 12-09-07, 06:35 PM
Member
Thread Starter
Join Date: Nov 2006
Location: Jersey
Posts: 526
Yea, the sender will be my first try.
Changed my oil and filter and I didn't see any metal in the oil or any junk in the filter which is a good sign.
I did pull the sender and it lookes good but you never know.
I'll run this week and see if the light comes back on.
 
  #4  
Old 12-09-07, 07:09 PM
Member
Join Date: Aug 2003
Location: Cape Cod
Posts: 4,320
Originally Posted by Mackey View Post
This week for the first time ever my oil indicator came on then went off and then at least once a day since Monday.

I am due for and oild change but not much over the 3,500 mile mark and i did notice I was down about 1/2 a quart last week.
My first thought is that the light is kicking on because it is low
And only occasionally because it's not "too low" just yet
I've had many cars that do this
-though admittedly it's usually a quart low for the light to kick on occasionally
Still...that's the first thing that came to my mind
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes