1 Wiper stopped working

Reply

  #1  
Old 12-14-07, 03:24 PM
Member
Thread Starter
Join Date: Dec 2007
Posts: 2
1 Wiper stopped working

I am not a mechanic, but I am trying to learn to do the small stuff so I could use your help. I have an 82 Caprice Wagon, less than 100k on it an in good shape. Passenger side wiper stopped working. The wiper can be moved by hand, and is not locked in place like it should be. Never messed with wipers outside of changing the blades. Do I need a new motor or is it possible just problem with arm?

Thanks,
CP
 
Sponsored Links
  #2  
Old 12-14-07, 03:31 PM
Forum Topic Moderator
Join Date: Mar 2005
Location: USA
Posts: 43,020
I don't know the specifics for your wipers... but I'd check to see if there is a way to tighten the wiper arm. Or take it off and make sure the stub is moving back and forth like it's suppose to. If the arm is stripped, go to a junkyard and get a replacement.

My wife used to have a new nissan that had a nut loosen up on the wiper arm. i thought it was broke but it only needed tightning
 
  #3  
Old 12-14-07, 05:01 PM
chandler's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Dec 2005
Location: USA
Posts: 39,968
The connecting rod to the right wiper has slipped off the motor transmission. It may be as simple as replacing it and the "c" washer that holds it on. Hopefully the rubber grommet is still intact.
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 10:58 AM.