GMC jimmy engine problem

Reply

  #1  
Old 02-03-08, 02:28 AM
Member
Thread Starter
Join Date: Jan 2005
Location: usa
Posts: 27
Received 0 Votes on 0 Posts
GMC jimmy engine problem

HI. I just bought a 1995 GMC jimmy 4.3 with 200k miles for a work truck. Runs fine with good power, the problem is if it idles for five or ten minutes it loads up (black smoke) and idle is bad. If i take off, it will clear up and run fine. I have it two days so i dont know much about it. Where do i start first?
Thanks
 
Sponsored Links
  #2  
Old 02-03-08, 09:08 AM
Member
Join Date: May 2006
Location: Iowa!!!!!
Posts: 3,967
Received 3 Votes on 3 Posts
Do a complete tuneup = plugs, wires, cap/rotor, air filter. Then remove the EGR and clean it. Check the Exhaust/catalytic converter for plugging. After that, if you still have a problem, get it scanned for fault codes, you may have an O2 sensor or water temp sensor acting up.

If you still have a problem, think about leaky injectors or bad fuel pressure regulator.

Hope this helps,

Bob
 
  #3  
Old 02-08-08, 07:05 PM
Member
Thread Starter
Join Date: Jan 2005
Location: usa
Posts: 27
Received 0 Votes on 0 Posts
Smile bad idle

Replaced the cpi fuel return lines (leaking) runs good now. Good for another 200k miles
Thanks for the help BOB.
Herbie
 
  #4  
Old 02-08-08, 07:38 PM
Member
Join Date: May 2006
Location: Iowa!!!!!
Posts: 3,967
Received 3 Votes on 3 Posts
Glad you got it going again. Thanks for posting back.

Bob
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description: