88 Chevy Corsica - turn signal problems

Reply

  #1  
Old 02-11-08, 03:31 PM
Member
Thread Starter
Join Date: Feb 2008
Posts: 3
88 Chevy Corsica - turn signal problems

1988 Corsica for some reason the right turn signal doesn't work. I have replaced all the bulbs in the cluster of the right-rear turn signal and the flasher unit has been replaced. The brakes work and the hazard lights work...any ideas what to check next?
 
Sponsored Links
  #2  
Old 02-11-08, 04:01 PM
HotxxxxxxxOKC's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2006
Location: USA
Posts: 8,044
Have you replaced the front bulbs as well?

Do the blinkers come on, but do not pulsate?

If they do not come on at all, I would suspect faulty wiring, usually corroded wires at the light assembly.
 
  #3  
Old 02-12-08, 08:16 AM
Member
Thread Starter
Join Date: Feb 2008
Posts: 3
The front blinkers and left rear come on and work just fine, it's only the right rear signal. They show to work from the driver's seat...It's just looking at the rear of the car, the signal doesn't light up.
 
  #4  
Old 02-12-08, 01:07 PM
mikeTN's Avatar
Member
Join Date: Dec 2007
Location: Nashville
Posts: 635
Question

Originally Posted by Amaresity View Post
The front blinkers and left rear come on and work just fine, it's only the right rear signal. They show to work from the driver's seat...It's just looking at the rear of the car, the signal doesn't light up.
if you have a voltmeter, pull the bulb, turn on the turn signal in question and check the wire for voltage.sounds like a bad wire or corroded terminal, if the bulb is good.
 
  #5  
Old 02-13-08, 06:24 PM
Member
Thread Starter
Join Date: Feb 2008
Posts: 3
Thanks Mike..I haven't had a chance to get a voltmeter, but I will pick one up tomorrow. I'll let you know if it works.
 
  #6  
Old 01-21-10, 10:16 AM
Member
Join Date: Jan 2010
Location: michigan
Posts: 1
Cool turn signal problem in my 88 chevy corsica

my blinkers are not coming on when i go to turn..no signal no sound, but every now and then they will come on while im in the middle of turning...( i still TRY to use them) they only work when the want to!

any ideas..i was thinking wiring or relay untill they started coming on again. we are buying a manual tomarrow. but an opinion may be helpful too!
 
  #7  
Old 01-21-10, 10:42 AM
Member
Join Date: Oct 2008
Posts: 1,312
Cleaning electrical connections is a big help!

Remove the bulbs, clean the connections, then squirt a bit of "dielectric grease" on the contacts.

Has there been any trailer towing wiring added?

If there are electrical connectors under the rear of the vehicle for the rear lights, disconnect them, clean with electrical contact cleaner, squirt a bit of dielectric grease on, then reconnect.

I'm afraid that the above probably will not do any good, but sometimes this is the problem and these things are easy to do.

Also be sure you have the correct factory specification bulbs installed.

Other than that, sounds to me like it would very likely be the turn signal switch. These can be a royal pain to replace. And you would need a factory service manual set for instructions on how to do this. And special tools are usually required.

Might want to take it to a mechanic if you are not experienced at this sort of thing.
 
  #8  
Old 01-21-10, 11:01 AM
Member
Join Date: Mar 2009
Location: Texas
Posts: 1,051
What about the 4-ways working? That might help you isolate it down to a quick repair around the signal relay.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'