2003 Explorer Just DIED!!

Reply

  #1  
Old 03-28-08, 12:43 PM
jobad72's Avatar
Member
Thread Starter
Join Date: Apr 2003
Location: Missouri
Posts: 49
2003 Explorer Just DIED!!

Hello,
I have a 03 Ford Explorer that just died at a stoplight last night and wont restart. The battery is good -ie- all the lights radio etc work fine. It is a v6 with about 66k miles. When i try and start it it does nothing at all. I plugged in a OBD2 Car Reader I got from my dad and it says error after it says read for awhile.

Oh, and when the key is on it displays dashes ----- where the mileage and outside Temp are usually at. Any ideas that could keep me from paying crazy ford labor prices would be greatly appreciated.
 
Sponsored Links
  #2  
Old 03-28-08, 04:03 PM
Banned. Rule And/Or Policy Violation
Join Date: May 2007
Location: Wisconsin
Posts: 8,629
The fact that it died at the stop light. Coincidence or not? The fact that it did - maybe the rpm's came down to stall speed without alternator and if battery was not getting enough charge, it finally shut off. Has anyone tried to jump start the car?

The dashes would indicate to me (just a hunch, not actual professional knowledge) that perhaps low voltage or computer would reset once car gets back full voltage in that circuit. Could be some major connection, ignition switch, fusible link, or a main fuse if your vehicle has such a thing, or the computer itself died, as just some guesses. Test in order of simplest to hardest.
 
  #3  
Old 03-30-08, 07:03 AM
jobad72's Avatar
Member
Thread Starter
Join Date: Apr 2003
Location: Missouri
Posts: 49
Found the problem. 15amp Fuse that was listed as the HEGO,VMV,CMS,PTEC, which i have no idea what it all means, but am happy it started. Thanks for the help.

PS- The battery was nasty also. Learned a lesson with this one. Thanks again.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes