battery or alternator

Reply

  #1  
Old 04-20-08, 12:55 PM
Member
Thread Starter
Join Date: Apr 2008
Posts: 1
Unhappy battery or alternator

I have an 89 geo tracker with a charging problem. charged the battery to 100% and started it up hooked up the charger while truck was running and switched the charger to alternator and was getting 100% from it but when i turn all my lights,heater,radio it drops to 0% and starts making a squealing noise so i turn it all off and the noise stops and i get 100% on the alt. Seem's to me it would be the alt. but the guy at schuck's said it could still be the battery. To replace the alt. is around $175.00 and the battery is $75.00 so i would like to just replace what is broken.
 
Sponsored Links
  #2  
Old 04-20-08, 01:22 PM
carguyinva's Avatar
Member
Join Date: Nov 2003
Location: Shenandoah Valley
Posts: 1,147
sounds like loose belt. try turning the pulley by hand (engine not running, of course!) If you can turn the pulley at all, the belt is loose. if it's loose, try tightening it and retesting. if the alt now produces with a tight belt, go ahead and replace the belt as the old one is likely glazed from slipping. half an inch of deflection for a v-belt with correct tension...and you shouldn't be able to turn that pulley either.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes