I think rear strut is broke.....


  #1  
Old 05-16-08, 04:11 PM
G
Member
Thread Starter
Join Date: Sep 2004
Location: New York
Posts: 580
Received 0 Votes on 0 Posts
I think rear strut is broke.....

Have a 96 Dodge Neon. Jacked up the right rear of the car to change a tire and noticed that the top of the strut or shock isn't connected to the top mounting piece of the car. Is this suppose to do this?
 
  #2  
Old 05-16-08, 04:54 PM
Unclediezel's Avatar
Member
Join Date: Dec 2006
Location: Northeastern PA.
Posts: 2,230
Received 0 Votes on 0 Posts
No.......

Check carefully...you have one of two possibilities.....

1--The strut mount is broken and will need to be replaced...or....

2- The body of the car has rotted thru and no longer holds the strut mount....

The latter.... depending on how much metal is gone...it may be possible to weld in a new "TOWER PLATE".

Either way...ASAP... have it repaired. The strut could concievably punch its way into the passenger compartment under a severe enough "BUMP".
 
  #3  
Old 05-17-08, 12:14 AM
G
Member
Thread Starter
Join Date: Sep 2004
Location: New York
Posts: 580
Received 0 Votes on 0 Posts
The strut mount is still solid in the trunk of the car. Pulled off the rubber cap on top of the strut mount and there was nothing under there. I don't even know what the top of the shock was connected to.
 
  #4  
Old 08-15-08, 01:40 AM
J
Member
Join Date: Aug 2008
Location: USA
Posts: 19
Received 0 Votes on 0 Posts
did you find the problem yet? i'm having a similar problem.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: