help 2000 eclipes

Reply

  #1  
Old 06-11-08, 12:16 PM
Member
Thread Starter
Join Date: Jun 2008
Posts: 1
help 2000 eclipes

Have a 2000 Eclipes all my gauges quit working how do i fix this problem Ihave checked all the fuses.
 
Sponsored Links
  #2  
Old 06-11-08, 09:51 PM
Speedwrench's Avatar
Member
Join Date: Apr 2008
Location: Oklahoma
Posts: 1,698
if everything quit at the same time I would start by checking the ground for the dash or instrument cluster. The other thing is check a manual to see if there is a voltage regulator for the instruments. I don't know about that model vehicle.

if we're not supposed to eat animals why are they made out of meat?
 
  #3  
Old 06-12-08, 03:53 AM
Member
Join Date: Jan 2006
Location: Ontario, Canada
Posts: 759
Perhaps same as neon. I had to remove trim around cluster & remove screws holding cluster to dash, then pull it out far enough to get at the plug at back of cluster. I ended up putting a slight bend in all the little pins/tabs, so as to allow for better contact at the plug terminals. One time I would start the car and gauges would all work, next time none, next time some? After doing that, all was working. Yours may be as simple as pulling plug off, and spraying connections with contact cleaner.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'