'99 Mazda Protoge a/c went out

Reply

  #1  
Old 06-17-08, 04:46 PM
Member
Thread Starter
Join Date: Jul 2005
Location: Riverside, Ca.
Posts: 20
Received 0 Votes on 0 Posts
'99 Mazda Protoge a/c went out

We are going to attempt to fix it ourselves before taking it to a professional. It's awfully hard to find an honest one.
I was driving to the mountains, so it was up hill (if that makes any diff.) and it just stopped working. It smelled a bit like burning rubber too. Any ideas of what belt or whatever to be looking for/at? Thanks jana
 
Sponsored Links
  #2  
Old 06-17-08, 06:38 PM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,820
Received 32 Votes on 25 Posts
A/C quit and had burning rubber smell would tend to point toward a locked up compressor. Near as I can tell from looking it up, your ac compressor may share a belt with the power steering. At any rate, locate the ac compressor and watch its pulley while someone else turns the ac on. You should see the clutch (the electromagnet around the belt pulley) engage. If it engages, but does not spin (and you see the belt smoking) the compressor is locked up; time for a professional.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description: