Howling Noise in 89 Olds

Reply

  #1  
Old 08-26-08, 10:59 AM
T
Member
Thread Starter
Join Date: Jan 2007
Location: Utah
Posts: 33
Received 0 Votes on 0 Posts
Howling Noise in 89 Olds

89 Olds with 3.8 V-6. 88 Royal 4 door.
I have a howling type noise when accelerating faster than normal. I'm pretty sure it's not the belt because it's not a screeching sound. AC still works great and the noise happens whether it's on or off. Maybe a vacuum leak? It also feels like the car has lost some power since this noise started.

Any ideas would be appreciated.
 

Last edited by Turbojohn; 08-26-08 at 11:39 AM.
  #2  
Old 08-26-08, 01:28 PM
E
Banned. Rule And/Or Policy Violation
Join Date: May 2007
Location: Wisconsin
Posts: 8,627
Received 0 Votes on 0 Posts
Do you have a radiator fan that has a clutch?
 
  #3  
Old 08-26-08, 02:22 PM
T
Member
Thread Starter
Join Date: Jan 2007
Location: Utah
Posts: 33
Received 0 Votes on 0 Posts
I thought it was an electric fan...but I'll check. Thanks
 
  #4  
Old 08-26-08, 04:01 PM
WTDR-DTY's Avatar
Member
Join Date: Jun 2008
Posts: 92
Received 0 Votes on 0 Posts
idler pully. 11111111111111
 
  #5  
Old 08-28-08, 04:01 PM
T
Member
Thread Starter
Join Date: Jan 2007
Location: Utah
Posts: 33
Received 0 Votes on 0 Posts
Originally Posted by WTDR-DTY View Post
idler pully. 11111111111111
Thanks for the tip!

Took the belt off and spun the water pump pulley by hand and it is squeaking, but spinning true. The idler pulley spins about 2 revolutions by hand....seems a little stiff, but no noises.

My guess is that it's the water pump going out or the idler pulley bearings. The noise only happens under load....going up hills when more throttle is needed.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: