94 Z24 Cavalier turn signals

Reply

  #1  
Old 08-28-08, 01:02 PM
Member
Thread Starter
Join Date: Aug 2008
Posts: 3
94 Z24 Cavalier turn signals

I have a 94 Z24 cavalier. The turn signals starts off normal but will slow down and sometimes stop working. Then I have to do it manually. All bulbs are fine and I just changed the relay under the dash. Any suggestions what to do next?
 
Sponsored Links
  #2  
Old 08-28-08, 06:06 PM
Member
Join Date: Feb 2005
Posts: 579
Next time, pull the lever back and hold it while the turn signal is on. Your bright lights will blind some people, but your turn signal might work better. If it does, your turn signal switch needs to be replaced.
 
  #3  
Old 08-28-08, 07:07 PM
Member
Thread Starter
Join Date: Aug 2008
Posts: 3
Thanks I will try that next
 
  #4  
Old 08-29-08, 09:03 AM
Member
Thread Starter
Join Date: Aug 2008
Posts: 3
Tried holding the bright lights on like suggested. Turn signals still not working properly. Any more suggestions?
 
  #5  
Old 08-29-08, 04:37 PM
Banned. Rule And/Or Policy Violation
Join Date: May 2007
Location: Wisconsin
Posts: 8,629
It's as if when heat develops from current flow, the current flow reduces (as in voltage dropping off).

I'd say you need a wiring diagram to see where all the connection points, are so you can do some voltmeter tests while it does this, to see where you still have fuill voltage, and at what location it drops off.
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 07:33 PM.