Camaro Defrost not working

Reply

  #1  
Old 08-31-08, 10:29 PM
Member
Thread Starter
Join Date: Apr 2008
Location: Syracuse, UT
Posts: 43
Camaro Defrost not working

1979 Camaro with a 350. The defrost isn't working and hasn't for about a year. The fan works and air blows out of the vents, but it won't come out of the defroster or the floor. If I close all of the vents then a some air comes out of the defroster, but not enough to keep the windshield clear. The temperature controls work fine. Any advice on where to start the troubleshooting?

Thanks
 
Sponsored Links
  #2  
Old 09-01-08, 06:13 AM
Member
Join Date: Jun 2008
Location: Eastern Georgia
Posts: 486
I suspect the vacuum control valve in the AC control head is bad or the adjustment has slipped. Try a simple test, go under the hood and disconnect the vacuum line going to the climate control system. Start the car and turn on the blower all air should be blowing out of defrost, if it is you will have to replace the control valve. Not a bad job, pull the control head the valve is the white plastic thing with 5 or 6 plastic tubes attached to it. See if the pin that moves it is broken off. They also will get too loose to work and just need to be replaced, but normally when this happens all the air goes to the windshield. There is always a chance something else is going on but this is the most likely suspect.
 
  #3  
Old 09-02-08, 10:59 AM
Member
Thread Starter
Join Date: Apr 2008
Location: Syracuse, UT
Posts: 43
I disconnected the vacuum hose that I suspect goes to the HVAC system. It was the one that was attached to a black ball type thing. With the hose disconnected the air is still coming out of the vents. What would be the next thing to test.

Thanks for the advice

Jon
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 10:08 PM.